Discover

Topics

Call Control for BroadWorks

Call Control for BroadWorks APK

Call Control for BroadWorks APK

1.11 $8.99NOMADICCIRCLE Ltd.

Companion app for your BroadSoft BroadWorks extension.

What's Call Control for BroadWorks APK?

Call Control for BroadWorks is a app for Android, It's developed by NOMADICCIRCLE Ltd. author.
First released on google play in 10 years ago and latest version released in 1 year ago.
This app has 2.1K download times on Google play and rated as 4.37 stars with 27 rated times.
This product is an app in Communication category. More infomartion of Call Control for BroadWorks on google play
NOTE: This app uses OCI/CAP and is not compatible with R22 - for the XSI based version of Call Control for BroadWorks, please check https://play.google.com/store/apps/details?id=com.nomadiccircle.ccbw


Call Control for BroadWorks allows you to originate calls from your Android phone through your BroadSoft BroadWorks powered desk phone and enables easy control of Remote Office, BroadWorks Anywhere, DND and Call Forwarding settings while on the move. If used with an account that is a member of a Call Center, joining/unjoining and control of the Agent ACD State is also possible.

IMPORTANT: Call Control requires service from a BroadWorks powered service provider and the account must include the following services
- BroadWorks Anywhere
- Remote Office
- CommPilot Express
- Simultaneous Ring Personal
- Calling Line ID Delivery Blocking
- Do Not Disturb
- Call Forwarding - Always
- Call Forwarding - No Answer
- Call Forwarding - Not Reachable
- Call Forwarding - Busy
- Basic Call Logs
- Client Call Control*
- Voice Messaging
- Call Recording
in order to benefit fully from this app.

* Without "Client Call Control" call initiation is not possible.

Note that the default port for OCI/CAP communication is 2208 - or 2209 if SSL is enabled.

Regarding ICS / Ice Cream Sandwich & Jelly Bean:
The app works well on Ice Cream Sandwich (4.0) and Jelly Bean (4.1, 4.2 and 4.2.1)- there are however some manufacturers that are a bit sloppy getting the device profiles updated, resulting in erroneously listing of apps not being compatible. If you have a 4.0/4.1/4.2 based device and the app is listed as incompatible, please contact support for a workaround.

If you have any other question, please do not hesitate to contact [email protected]